Overview not working in Scrum Dashboard v3 RC1

Oct 15, 2010 at 1:15 PM

Hi!

In RC1, the overview is now working without errors, ONCE, the second time I load the project I get the same error as before!
After restart of browser, it works once again!!!

One other problem is that the burndown chart isn't displaying at all, not even once.
Maybe this also has to do with that we have a space character in the project name?
Or is there any configuration needed?
The burndown chart is working for the specified project if displaying it in the Reporting Services web interface.

If I look at the html code generated and copies the http url to the image it looks like this:
http://ourserver:8081/ReportServer?/TfsReports/Development/Caesar%20CRM/Sprint%20Burndown%20Chart&rs:ClearSession=true&rs:Command=RenderStream&rc:LinkTarget=main&rs:Format=HTML4.0&pReleaseWorkStreamPath=\Caesar+CRM\2010.12+-+Caesar+CRM+2010+SP1\Workstream\%25&pSprintTeam=\Caesar+CRM\2010.12+-+Caesar+CRM+2010+SP1\Workstream\Sprint+02\%25&rs:ClearSession=true&rs:ImageID=C_26iT0_1

And if I paste this url into a blank browser window I get the following error:
Reporting Services Error

* The stream cannot be found. The stream identifier that is provided to an operation cannot be located in the report server database. (rsStreamNotFound) Get Online Help

SQL Server Reporting Services

Regards
Andreas

Coordinator
Nov 4, 2010 at 1:53 PM

Regarding the first issue, make sure you clear the browser cache. It was just a javascript encoding issue so I can't see how this problem could come and go in any other way than the javascript being cached by your client.

Regarding the second issue: When you display the report in the Reporting Services web interface, can you right click on the burndown image and post the URL here as well. Verify that the ImageID matches because that can be configured in web.config.

 

Coordinator
Nov 4, 2010 at 2:11 PM

I added encoding for the project in the reporting services URL even though I can't see how that would fix your problem since all sites haves spaces in the report name. If you want to try it, just download RC2.