Open wrong work item page when use multiple collection

Feb 15, 2011 at 5:16 AM

I have two collection:

1. defaultcollection

2. Business

There are many projects in two collection.

My problem is when I click one work iterm in Business collection, a same number work number in defaultcollection collection is opened.

Then I check web link, here is dashboard link:

http://tfsserver:8080/tfs/web/wi.aspx?id=39 

But I also check TLF web site open same work iterm in BUsiness collection, I found link as follwoing:

http://tfsserver:8080/tfs/web/UI/Pages/WorkItems/WorkItemEdit.aspx?id=39&pguid=4c644dde-f3f2-42e0-a8e3-89a17120e297

I know wi.aspx is mapped /UI/Pages/WorkIterms/WorkItermEdit.aspx.

So I guess in dashboard the work iterm web link miss parameter for pguid.

If missing pguid parameter, then application auto to find work iterm ID in deaultcollection.

Look forword to reply.

Thanks.

 

Feb 15, 2011 at 7:07 AM

Another issue is about teams.

After open a project, the first line show project/sprints/teams dropdown list.

The teams dropdownlist only show <All> and New Team Sprint, can not show correct team name.

Thanks

Feb 17, 2011 at 9:26 PM
coke wrote:

After open a project, the first line show project/sprints/teams dropdown list.

The teams dropdownlist only show <All> and New Team Sprint, can not show correct team name.

It's possible that you didn't set up the Release, Sprint, and Team Sprint work items with all appropriate links. My best suggestion is to use the TFS Workbench tool provided by EMC for setting everything up.

Coordinator
Feb 22, 2011 at 2:41 PM

Regarding the links to work items in the non-default collection, it has been fixed in v3.0.3

http://scrumdashboard.codeplex.com/releases/view/61436
http://scrumdashboard.codeplex.com/workitem/10122

Feb 24, 2011 at 9:02 AM
Edited Feb 24, 2011 at 9:03 AM

miss content

Feb 24, 2011 at 9:03 AM
HolisticDeveloper wrote:
coke wrote:

After open a project, the first line show project/sprints/teams dropdown list.

The teams dropdownlist only show <All> and New Team Sprint, can not show correct team name.

It's possible that you didn't set up the Release, Sprint, and Team Sprint work items with all appropriate links. My best suggestion is to use the TFS Workbench tool provided by EMC for setting everything up.

I used TFS workbench tool to create everything.

Have you get correct team sprint info?

Thanks