Install Issues

May 18, 2009 at 5:15 AM

I see a post about my first issue: By commenting out the following in web.config I progressed to the next error:

     <!--remove name="CompressionModule" /-->
      <!--remove name="ReportWrapperModule" /-->

I then had a problem in that it couldn't find "Microsoft.TeamFoundation.WorkItemTracking.Client" went through hoops to finally get all the required assemblies in the GAC.

Now everytime I go to http://server/ScrumDashboard I get :

Server Application Unavailable

The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request.

Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.

I see in the event log:

Event Type: Error
Event Source: ASP.NET 2.0.50727.0
Event Category: None
Event ID: 1088
Date:  5/18/2009
Time:  5:03:59 PM
User:  N/A
Computer: VM303TFSTST
Description:
Failed to execute request because the App-Domain could not be created. Error: 0x80004005 Unspecified error 

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Have been googling and trying various things but can't seem to get past this.

Win 2003 Server R2, MS SQL 2005, MS 2008 TFS

Coordinator
May 19, 2009 at 5:47 PM

Are you following the installation instructions ?

http://scrumdashboard.codeplex.com/Wiki/View.aspx?title=Installation%20instructions

The first error should not happen (the lines you needed to comment) if you are installing Scrum Dashboard under the TFSWA site. Also, you must have Team Explorer installed which automatically installs the assemblies in the GAC (which also should be there if you are installing in the TFSWA site).

Jun 10, 2009 at 4:16 AM

Yes followed the instructions. Team Explorer installed etc. I'll come back to this latter on in the month.

Nov 16, 2009 at 5:00 AM

i'm facing the same problem.  Anyone did solve this?

 

Failed to initialize the AppDomain:/LM/W3SVC/1807584280/Root/ScrumDashboard

Exception: System.IO.FileLoadException

Message: Could not load file or assembly 'System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Access is denied.

StackTrace: at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)

at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)

at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)

at System.Activator.CreateInstance(String assemblyName, String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes, Evidence securityInfo, StackCrawlMark& stackMark)

at System.Activator.CreateInstance(String assemblyName, String typeName)

at System.AppDomain.CreateInstance(String assemblyName, String typeName)

at System.AppDomain.CreateInstance(String assemblyName, String typeName)

at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)

at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Nov 16, 2009 at 11:41 PM
Edited Nov 16, 2009 at 11:43 PM

Yes I did get it working, but I can't remember exactly what I did. From memory I think it was v.important to check the pre-req's and follow the install exactly. Here's some information from an internal email I found, hope this helps:

Prerequisites

 

a)      Windows Server 2003

b)      MS SQL Server 2005

c)      IIS 6.0

d)      TFS 2008

e)      Team system Web Access 2008

f)       Scrum for Team System V2

g)      .Net Framework 3.5 SP1

 

The current production TFS Server xxxxxxx is running TFS 2008 Version 9.0.21022.8. The same version was installed on xxxxxxxx.

 

It is not necessary to upgrade Team Foundation Server to 2008 SP1.

 

Install steps

 

Install prerequisites (the others were already installed):

 

Team System Web Access 2008

Scrum for Team System V2

.Net Framework 3.5 SP1

 

It is not necessary to upgrade Team Foundation Server to 2008 SP1.

 

  1. Unzip the downloaded ScrumDashboard package to c:\inetpub\ so you get a ScrumDashboard folder (the subfolder Web will be the web root)
  2. Create a new application pool ScrumDashboard with default settings in IIS Manager (it does not require a domain account because the currently logged in user will be impersonated)
  3. Create a new virtual directory ScrumDashboard in the Team System Web Access site in IIS and select the Web subfolder in the scrum dashboard folder
  4. <sup>*</sup> 
  5. Create a database user and assign full access(dbo) rights to the ScrumDashboard database

 

* A new database is required by Scrum Dashboard, this can reside in the TFS SQL Instance or on a different server and instance. The connection to the Scrum Dashboard database is configured in the “web.config” file for the virtual directory of the application.

 

IIS – The install steps above using the default settings implements the “default content page” as “index.aspx”. I was getting HTTP 403 errors until I figured this out and changed it as show below.

screenshot missing here - from IIS Manager, modify the ScrumDashboard proerties on the Documents tab. Enable default content page and add "default.aspx".

 

 

Reference:

 

http://scrumdashboard.codeplex.com/

Nov 17, 2009 at 1:09 AM

I solved the problem in our environment.

Go to IIS Manager, under Team System Web Access, right click on the ScrumDashboard virtual directory and click Permission.

Add Network Service with at least read permission.

This solved my problem.