Cannot create task in Sprint

Jun 9, 2009 at 7:32 AM

Using the Scrum Dashboard we encountered a problem.

 

Some users can't create a task (sprint backlog item) to a Product backlog item.  When creating a new task, we got the popup.  Filling in the 3 fields and then pressing create gives a message "Error on page".  Viewing the detail of this error :

"Sys.Webforms.PageRequestManagerServerErrorException: TF26201: This Work Item has unsupported fields, or user does not have permissions".

I have enough rights As I'm TFS Administrator and this group is always in the project admin group.

Adding tasks to another sprint doesn't give any problem.

Also adding a task in TFS directly for this sprint also works, but this task isn't showing up in the scrum dashboard.

Hope you could help us out with this issue.

Txs in advance.

Coordinator
Jun 22, 2009 at 11:15 AM

The events from TFS to Scrum Dashboard is probably not working if new tasks created in TFS is not showing up in Scrum Dashboard, events are registered using bissubscribe as described in the installation instructions. Verify that the URL you are registering is accessible from TFS.

Jun 23, 2009 at 6:49 AM

Txs for the answer.  The URL was working and I could add a task ion VS and it appears in the Scrumdashboard.  The problem was that we didn't put a link to the Product backlog item.

But the main problem still exists.

 

For one sprint we couldn't add sprint tasks with the scrumdashboard.  If we add sprint tasks with VS everything works. In other sprints, we could add sprint tasks using the scrumdashboard.

this happens when we couldn't add a sprint tasks:

When creating a new task, we got the popup.  Filling in the 3 fields and then pressing create gives a message "Error on page".  Viewing the detail of this error :

"Sys.Webforms.PageRequestManagerServerErrorException: TF26201: This Work Item has unsupported fields, or user does not have permissions".

trying again, all info entered before is already filled in (even in antoher sprint.).

I have enough rights, because I'm the TFS adminitrator and have administrator access to the server and all projects.

Hope you know what's wrong here.

Coordinator
Jul 3, 2009 at 7:00 AM

Don't now the answer to this one, make sure you enabled the correct authentication on Scrum Dashboard, is this a single server setup ?

Can you try to recycle the application pool and see if that helps ?

I've had a similar problem with TFSWA that was solved in this one by adding a specific globalization element to web.config: http://social.msdn.microsoft.com/Forums/en-US/tfsworkitemtracking/thread/eeaf4e95-3ab5-40e3-a189-ccc79635adff

 

 

Jul 16, 2009 at 6:48 AM
Edited Jul 16, 2009 at 12:24 PM

Hi Perb,

Txs for the answer.

Unfortanatly, this doesn't work.  I also have cleaned the local cache of the user.  It also didn't solve the problem.  We also can't change the config setting.

It's even getting worser.  We now have a second sprint with the problem.

In the first sprint, we couldn't add sprint items to all product backlog items. getting the error above.

In the second sprint this occurs only on one product backlog item.  For the other product backlog items we could add sprint items.

We found out what the problem creates.

If on the Product Backlog Item the team is filled in, we couldn't add Tasks to this PBI.  When the team is blanc, there's no problem.

I'm going to look at the code for it, but probably this is a bug in the software.

We are using v 2.3.0.0.  Maybe you could confirm that this problem is solved in v 2.4.0.0. 

Hope you could give a positive answer about the new version or that you oculd reproduce the bug with this information.